Science! – Four, no, 31 1/3 months.. part 11 of ?

Here we go..

In my last post I had printed out two sets of RepRap parts for new RepRap printers.

The set on the right was a birthday present for my brother Jon, and the set on the left was to become a 2nd printer for me. But as I mentioned, I re-purposed that set that was initially made for me, and built it for someone else. We’ll talk about who in this post.

(Lots of pics in this post.. don’t quit mid-way – even if you’re not into the printer details, make sure you make it to the end, even if just to answer the end of that last paragraph).

As I’ve had to do for the past 11 posts or so, I have to remind you all again, I’m about a year and a half behind. Today is July 27th 2013, but I’m posting about events starting on January 28 2012.

So by January 13th 2012 we had solidified a date for the first meeting of the New England RepRap group: February 26th, 2012. We mailed it out on a bunch of different forums and on our old Google Groups list. The idea would be to have a bunch of people bring their RepRaps (or lesser, non-self-replicating printers 😉 ) to one place, set them up, and have an excuse to print for the whole day.

We were having trouble finding a good location, so I offered the use of my house. Initially I wasn’t sure what to expect.. I thought there was a good chance it could be awesome, but feared the possibility that it might just suck. Wow was it ever the former – everyone who came was really glad to attend, and wanted to know when the next one was.

But before that, someone named Julia from the Museum of Science in Boston sent out a few emails looking for people who might be willing to lend the museum their 3D printers. The Museum was planning a three-week exhibit on 3D printing.

I practically grew up in the Museum of Science – we went as kids like fifty times at least. Anyone remember this commercial from the 70s?

The net that Julia cast hit me from two directions – she sent mail on our thread about the New England RepRap meetup, and she sent mail to MIT alumni (which a coworker sent me).

She had asked about borrowing a printer. I told her that I had a self replicating printer, so why didn’t I just make the Museum one for it to keep? I talked about the cost of vitamins (non-printable parts) and said I’d be willing to print them parts, foot the initial bill, build it, get it working, show them how it works, and maybe if they had $ later they could pay me back for the vitamins. They liked the idea a lot.

I ordered some of the vitamins (again, non-printable parts – mcmaster.com stuff like nuts, bolts, and threaded rod) for 4 sets of RepRaps: one set for a coworker, one set for my brother, one set for my eventual 2nd RepRap, and one set for the Museum of Science’s RepRap. Once that order arrived, I started building.

I took the parts that I had printed for my 2nd RepRap and used them instead as the parts for the Museum of Science’s RepRap. At the same time that I physically built the Museum of Science’s RepRap, I also had my original RepRap printing a 3rd set of parts to replace the ones I just gave the Museum (to eventually be my 2nd RepRap).

I printed frame vertex pieces with feet (the one on the right looks like it curled up):

Then rather than going through a few parts at a time, I decided to try printing a full plate again (this time – Prusa IT2 plate #3).

…and then it finished..

Then on to the next tray.. plate #4

I took a break from RepRap parts and printed some more keychain bottle openers. Here’s the awful-quality one that I’d been carrying around on my keychain compared to the new ones on my nicely working printer:

The mcmaster order arrived, and I started assembling the RepRap for the Museum of Science. Here is what a tube filled with enough threaded rod for 4 RepRaps looks like:

Here was the also-heavy box of nuts/bolts/etc:

Before I get to the build, here was a quick video I wanted to record about how much easier one aspect of this was now than 2-3 years ago when I was making my original Mendel:

Ok.. The build commences.. First, the triangles:

Then I make sure the second triangle is the same size by temporarily inserting some M8 bolts:

Then I added the two front/lower bars (note I was still using the bearing guides on the 608 bearing at this point):

Then the two back/lower bars:

Then the top two:

I mounted my Z-motor holders slightly different than the instructions said. On the recommendation of someone in the forums (I believe it was in this thread), I decided to put an extra nut between each top frame vertex and its neighboring z-motor-mount piece, such that it goes vertex-washer-nut-(space)-nut-washer-zmotormount. (So I used an additional 4 nuts in all, one for each bar on each side). This allowed me to move the z-motor-mounts to help line them up with the X-axis, and it slightly increases my X travel distance. It did mean that my X smooth rods were longer than normal – I cut mine to 412mm instead of 405/406mm.

Then I added the bottom middle bar

Next was the bed. I printed out the template and taped it to the MDF bed I’d cut out, lined up with two diagonal black lines I’d drawn on it to center the template. I also marked the drill holes on those black lines through the PCB heatbed.

Now the LM8UUs that I received were much shorter than other LM8UUs I’d seen, and didn’t really fit well into the LM8UU holders of the standard Prusa IT2 parts. So I printed out replacement Y-axis holders and a replacement X-carriage.

Back to the bed.. I mounted the Y-LM8UU holders (I left the paper on, which would later be a bit of a pain if I remember right). Note that in place of one of the belt clamps, I installed a Y-belt tensioner. Unfortunately where I mount it in this picture wasn’t good, because the belt I ordered was exactly as long as it needed to be for a Prusa IT1, so there wasn’t enough extra belt to go around the tensioner and get clamped in. (I later moved the back belt clamp near the end of the bed, robbing the bed of a small amount of Y travel).

I put a printed pulley on the Y stepper motor and mounted it, then ran the belt and attached it to the bed.

(If you look close in the next picture you can see the back belt clamp screws are much further back)

In this picture beneath the bed you can almost see how the belt tensioner works – the black belt on the top goes through a hole on the top, goes around the horizontal bolt that you can see in the tensioner, and then comes back towards the front and is clamped between the two plastic pieces. If you turn the screw to the right you move the bolt ahead a bit and add some tension to the belt.

Then I assembled the X axis. Now despite the friendly ribbing that I’ve given Josef Prusa about naming his RepRap after himself, the X-axis is where he really deserves credit. The original Mendel X-axis (excluding the carriage) used thirty (30) separate printed parts, 52 nuts, 136 washers, 54 screws, and 16 bearings. The Prusa IT2 X-axis (excluding the carriage) uses TWO printed parts, 6 nuts, 4 washers, 4 screws, and 4 bearings (and 2 springs). The only downside is there wasn’t a standard integrated mount for the X-endstop board or the Z flag. I definitely enjoyed assembling my original X axis, but the Prusa version is much simpler with far fewer parts.

Meanwhile, I tried and failed at my first attempt printing ABS parts on my first Mendel (I haven’t tried since – today is July 27th 2013):

Back to the Museum of Science’s RepRap – focus! 🙂 I then went to Home Depot and found a good sized fender washer to use instead of the plastic ones I’d designed/printed. That made things much better.

Now it was time to connect the X-axis up to the Z-motors via leadscrews to form the Z-axis. Now I know that some harsh words have been flung around about using a level in almost any capacity during RepRap construction (I think I remember Whosawhatsis saying something about some book that was coming out), but I humbly disagree that it’s without use. Sure, the relevant part is that the bed is relative to the X-axis (not the ground), but using a level is a quick way to get at least a rough
measurement at first (which you can refine later by twisting the leadscrews). (There’s my disclaimer when you see a level in the next few photos).

Here’s what I did.

First, I made sure the bed itself was level on the table. I shoved paper shims beneath legs until it was level to the ground (so that I could use gravity to help line up the smooth rod connections etc). Once I made sure the bed (which on an IT2 isn’t adjustable) was level, I ran two strings with weights on the end of them over the top of the Z-motor mounts. (I used a plumb line on the left – I should have just used thread tied to an M8 nut).

I ran the string over the top of the Z-motor mount (and over a small drill bit, so the string would go in the center of the clamp where the smooth rod would go), then down through the LM8UUs in the X-axis (and then to the weight at the bottom). This meant the X-axis had to be lifted off of the bed, so I rested it on some plastic parts of known size.

Here was the left side:

…and the right:

Here you can see both sides, with strings passing through each end. Since the X-axis was of a fixed length, I had to adjust where the Z-motor-mounts were (with those extra nuts I added earlier) to get everything to line up:

Here are shots looking down the string so you can see how they lined up. I used this view to adjust the Z-motor-mount positions. First the right, then the left:

Once that was all lined up, I could adjust and tighten the location of the lower bar, the location of the bar clamps on that bar, insert the Z smooth rods, and clamp everything tight. Then the X-axis slid up and down smoothly to form the Z-axis.

I zip-tied in the smaller-than-usual LM8UUs that I had to the ends of the X-axis.

The way that Prusa’s X-axis interacts with the leadscrews is via trapped nuts (just like the original Mendel), but rather than trapping them tightly inside blocks of plastic, they’re lightly held inside a hexagonal chamber. The trick is that you have two nuts on each side (I think it was listed as “optional” but I don’t know anyone that hasn’t installed both). Each side has two M8 nuts – one on top, one below, with a spring inside to keep them under tension.

These were the springs I found and used:

They are the 1″ long springs with 27/64″ diameter (big enough to easily fit around the M8 rods and inside the channel). That assortment pack came with 4.

I rested the X-axis on the bed and screwed in the leadscrews, compressing the springs between the nuts. (You can see the upper nuts lower than the top of the plastic, since they’re unable to spin).

Then I made the mistake of putting the Z-couplers on the Z-motors a bit too soon. At least it made for a nice picture:

(Some people missed the need for that tubing. It’s needed. But apparently it can slip, and that’s why people also make couplers out of metal that hold better).

Here’s why it was too soon:

Doesn't Fit

I dismantled the couplers, fit it through, reassembled the couplers beneath the motor mount, and left some space (didn’t tighten it all the way, but just tight enough to hold onto the plastic).

I rested my X-axis on my level to lift it off of the bed (so the leadscrews could reach), and one by one turned the leadscrews such that they raised up and into the couplers. This picture shows just the right one turned up, and the left still down:

Once I had both screwed in, and only because i knew my RepRap frame (and bed) was level to ground via the paper shims, I put the level on the X-axis and got a rough estimate of how much to turn each leadscrew to make sure my X-axis was level (to the bed, and coincidentally to the ground). I would later refine this once I had a hot-end installed that I could run left/right/back/forth across the bed from about 1mm above it.

Here is the Z-axis suspended entirely by the leadscrews:

…and here it is with the x-belt and x-motor attached:

Once I got the Z axis working, I was psyched to see how fast it was. I had my original Sells Mendel dialed down to some crazy-slow 32mm/sec because it gave me problems faster than that. With the new machine that is not a problem:

Finally I got all of the axes working. Here is X, Y, and Z axis motion!

This was the minimum needed for the Museum of Science’s 3-week 3D-printing exhibit. They basically had it on stage while they talked about 3D printing, so it didn’t need to print just yet. Those pictures above were taken on February 13th 2012. The next day, February 14th 2012 (a Tuesday), I drove the printer-without-an-extruder to the Museum.

Here it was in the back seat:

I brought it in and showed the X, Y, and Z axes working before the talk. I managed to grab a few pictures of it that show the Museum all around it. I loved getting these pictures – I grew up loving this building as much as Canobie Lake Park, and now something I’d built was on display there (even if only for 3 weeks.. yet).

Me with my visitor sticker:

…and if you look closely up on the stage you can see the RepRap to the left of the skeleton:

I left that night, leaving the printer in their possession. That was Tuesday. As it turned out, my daughter Emily was going to have a school field trip on Friday (the 17th), and I offered to help with one of the talks that day. On Friday I brought in my printer – my original Mendel, so I could show it off actually printing.

My original Mendel looks much beefier in the car seat both because it is, and because it had a spool of plastic, full electronics wiring, etc.

Emily and I sat together for the presentation (I did the printing demo and Q&A on stage after the talk):

Here before the talk you can see my printer on the center grey table:

And in the upper right of that pic was the schedule for talks, with me in-between the two talks.

Ooooh.. Expert. 🙂

Then the talk..

Sadly I don’t have any pictures of my demo or the Q&A.

Then Emily’s group had to leave. It was cool being able to let Emily’s schoolmates finally see what a 3D printer looked like and to see it printing. 🙂

I managed to grab a shot of my original Mendel in the same looking-up-the-escalator shot as the printer I made for the Museum:

I left after that, taking my own Mendel back home but leaving the Museum’s printer-without-an-extruder with them for the next two weeks.

Then I came back into the Museum to pick it up again, so I could finish work on it so they could have a working RepRap to keep. To help me carry it out, I brought along my trusty helper Cara.

After sitting through the talk again, we met up with Julia who handed us back the unfinished RepRap. That meant that Cara got to go in a very special room, that only people who worked at the Museum got to go into. She loved that she got to go somewhere that others couldn’t. 🙂

Julia talking to Cara, making her feel incredibly special:

Cara happy on the ride home:

That’s how I felt too. 🙂

More next time on that first New England RepRap meeting. We’re really close to being caught up (event-wise). This catches us up to February 25th, 2012 (and again, today is actually July 27th, 2013).

2 Responses to “Science! – Four, no, 31 1/3 months.. part 11 of ?”

  1. Geoff says:

    A very nice piece of work, makes my prusa look a bit Heath-Robinson!

  2. nuttzy says:

    Looking forward to seeing your work at MoS this Friday!!

    Make sure you save that original bottle opener. It will be amazing to compare it against whatever we are producing 20 years from now!

Leave a Reply