15+ tries later, buying better stepper motor

Since my last post I’ve done over 15 print attempts.. I fixed a bunch of things during that time, and felt I was making at least some progress, but I’ve realized that I simply won’t be able to print anything real with the Mercury stepper motor I’ve been using for my non-geared, standard Mendel extruder.

Today I ordered a high torque stepper motor with a 3/16″ round shaft (Lin Engineering 4218L-01-10) for around $10. I’ll cut splines into that shaft too (as I did with this one), and hopefully get enough torque that I can dig into plastic enough to get consistent extrusion so I can print a geared extruder (or, one thing at a time, print anything). :)

The new stepper motor is due to arrive Tuesday. I won’t be doing much until then.

All of that said, here are a few pics and video clips of some of my print attempts up to this point (after a few gratuitous 3D pictures of my Mendel):

NOTE: With the lazy-eye 3D pics, I’ve found it’s best to click on the pictures first, then try doing the 3D thing. WordPress tries scaling these to make them bigger, and in this case bigger is not better – it makes it very difficult to line up the images, and then there are scaling artifacts.. Click the pictures so they’re in their own un-scaled original forms first.

I love this first one – note the wires, the pool in the back, the table beneath it, the foremost threaded bar with the power cables on it, etc.

Look at this next one and see if anything looks “wrong”:

It took me looking at that above 3D image to realize that one of the M8 bolts on the top had almost come off from vibration. I had the actual Mendel right in front of me and didn’t notice it, but the 3D picture had me studying every bit of it and I noticed. :)

Here’s one last 3D pic:

Ok.. Here was video of JeffTry6, where I briefly got optimistic enough that I almost sound like that “double rainbow” guy (shiver):

Here was the result of that:

..and me talking about that:

So then I went about doing the math to determine what the number of steps/mm I should have for Z, and for that matter, for X and Y. I have McMaster pulleys (McMaster part# 57105K11) for my X, Y, and Z stepper motors, which have a larger diameter than the printed Mendel pulleys. For X and Y it’s easy:

// One step is the circumference of the pulley divided by the number of steps)
1 step = (McMasterPulleyDiameter * π)/ 400 mm
so
1 mm = 400 / (McMasterPulleyDiameter * π) steps

(where the 200 step (1.8˚) motors are in half-stepping mode, so we use 400)

That means my X_STEPS_PER_MM and Y_STEPS_PER_MM are 7.869315719200254 (I put 7.8693).

For Z there are two gear diameters and the leadscrew pitch to deal with too. For Z, my math was:

// 1.25mm pitch screw, 1 full turn, 1.25mmz
1.25 mm-of-Z-travel = (RepRapLeadscrewGearDiameter * π) mm-of-belt
so
1 mm-of-belt = 1.25 / (RepRapLeadscrewGearDiameter * π)  mm-of-Z-travel

Then combine that with the previous equation for 1 mm-of-belt from above:

// Same as above
1 mm-of-belt = 400 / (McMasterPulleyDiameter * π) steps
and you get
400 / (McMasterPulleyDiameter * π) steps = 1.25 / (RepRapLeadscrewGearDiameter * π)  mm-of-Z-travel

which reduces to:

1 mm-of-Z-travel = (RepRapLeadscrewGearDiameter / McMasterPulleyDiameter) * (400 / 1.25) steps

Maybe my measurements were wrong, or I’m taking the diameter of the wrong part of the gear.. My X/Y value seems ok, but my Z value didn’t work in practice. McMaster’s site says the diameter of that pulley is .637″ (16.1798mm). I measured the RepRapLeadscrewGear at around 1.125″ (28.5750mm). That gave me 565.1491 steps of the Z-axis motor to move the X axis up or down 1mm. So I set Z_STEPS_PER_MM to 565.1491 (in firmware, and also in the Preferences page), and it didn’t turn out right. It turns out the correct value through experimentation was 672. If someone wants to tell me where I got my math wrong on that one, I’m all ears (but again, it could just be the wrong measurement). And by the way, thanks to Laurie for verifying the math by solving the problem independently from me so we could compare our results.

Here’s how I determined the Z_STEPS_PER_MM through experimentation:

At some point after this I realized to my shock that when the nozzle moved towards the right on the X axis, the nozzle raised higher and higher above the bed. I’d previously spent time making sure this wasn’t the case, so I worried about how that had happened. The first thing I did was check the bed height with the spacer piece, and determined that the bed was correctly leveled. Then it hit me and I felt crazy for not having seen it immediately – the right leadscrew was somehow now a few turns higher than the left leadscrew. I think this happened when I’d been working to fix the Z axis problems I had a month or two ago. Anyway, I loosened the Z belt, adjusted it meticulously, tightened everything up again, and that’s all fixed now.

Then I proceeded to do more attempts at printing. JeffTry10 didn’t look very good at all..

Then another..

The best example of the fact that I’m not consistently extruding but rather dribbling with some slight push was this attempt at printing a 40mmx40mmx40mm cube, which I only let go for maybe 2 layers before aborting:

Before deciding to buy a new stepper motor with higher torque, I figured I’d give it one more try, this time changing the extruder firmware to use full steps instead of half steps, which I think should increase the torque. I certainly got more plastic out, but as you can see, it’s still not extruding correctly:

Here’s one more 3D picture of that print attempt, then a picture, then video:

That’s it for now. More next week!

12 Responses to “15+ tries later, buying better stepper motor”

  1. nuttzy says:

    Looking forward to Tuesday!

  2. I really think you will save yourself a lot of headaches by going to one of the geared extruder designs. I am currently using a Wade extruder which I like very much except when I have to work on the hot end. On my second Mendel I want to try to use Adrian’s geared extruder design. It would have saved you from buying a new stepper motor! :-)

    • jkeegan says:

      Yeah that’s my plan.. The Makerbot that I and my friend Chris built belongs to work, and we were able to borrow it long enough for me to print out my parts. We had to give it back, so I’m kind of stuck with the parts I have now, and I also am emotionally invested in this particular extruder at this point. :) I am on the list to borrow that same Makerbot back again though, just in case I don’t get this working any time soon. I’m so close though that I doubt I’ll need the Makerbot to print either Wade’s or Adrian’s extruder – I’ll probably print one of each once my Mendel is working, and try them both.

      Actually I’m waiting for more details on Adrian’s Geared Extruder Nozzle (blog post here) to be documented, as that would prevent me from having to worry about parts of Adrian’s extruder being glued to the PTFE – so that may push me to making Wade’s first.

  3. nophead says:

    Jeff,
    When calculating the Z steps you don’t use the pulley diameters because the belt is toothed. You just use the number of teeth on the two pulleys. Similarly on X and Y you just use the belt pitch and the number of teeth.

    Chris

    • jkeegan says:

      Of course! (slams palm against forehead).

      Thanks! Now I can’t wait to get home and do the exercise of counting the number of teeth and redoing the math.

  4. rbisping says:

    also, just getting close numbers will allow you to print a calibration cube with which you can finalize your numbers. also with the amount of print material you were getting if you had slowed your print speed down to about 10mm/s you might actualy get good or at least usable prints that you could then print a extruder with. but getting the right motor is definatly the CORRECT answer :)

    • jkeegan says:

      I certainly tried! I modified all of the print speeds I could find down as slow as would actually extrude, but that didn’t seem to help. Come to think of it, I may not have tried that again after switching to full-stepping on the extruder motor, which is when I was getting that amount of plastic.

      It WAS going very very slow at the end of the print, which is how slow I expected it to be going during the entire print while trying to slow things down.. (which is actually caught in one of the videos above). Maybe there was some issue with the reprap host software? Before I go assuming that though I’ll try some more experiments. I’m trying hard to resist the urge to go back to Skeinforge for generating my gcode files (if it is even ready to generate Mendel/FiveD compatible gcode – I can’t remember the status of that). Skeinforge/ReplicatorG is obviously what I was using on the Makerbot when I was printing the pieces for my Mendel.

  5. Bodgeit says:

    A geard extruder is so much better as you can use a tiny little stepper to get 4k of push to the extruder.
    Your X Stepper seems to sound quite loud in the clips as I could hear lots of vibration in the x moves reducing the drive current on X will improve the noise/vibration levels.

  6. nuttzy says:

    Is it Tuesday yet?

Leave a Reply